Tag Archive for: Cumulative Update

SharePoint 2013 CU August 2013 – “Internet Information Services not installed”

24 Feb 2014
February 24, 2014

Today it was time to update my SharePoint 2013 installation from March PU 2013 to August 2013 CU – mostly because the Search Schema changed under the hood and I wanted to try something out for the awesome Search Query Tool.

Download

Wow, 1.8GB patch – that is huge! Compared to the RTM version of SharePoint 2013 with 2.4GB they rewrote 75% – or the patching strategy is not that optimal.

MSDN Subscriber Downloads_2014-02-21_15-36-30

Its time for a new baseline so patches can be smaller again. Lets see what happens after the SPC.

You can grab the SharePoint 2013 CU August 2013 patch here: http://support.microsoft.com/hotfix/KBHotfix.aspx?kbnum=2817616&kbln=en-us

KB Details here: http://support.microsoft.com/kb/2817616

Patch notes of Todd Klindt (my inofficial SharePoint patch guru) are here (and no regression reported): http://www.toddklindt.com/blog/Regressions/SP2013Aug13.aspx

Patching

For the patching part I always take the script from the article

“Why SharePoint 2013 Cumulative Update takes 5 hours to install?” – if you have not read it, go for it. This time something went bad, maybe because I started the script from ISE or something like that – it could not start the patch process so I did it myself. Took around 30 Minutes on my DEV VM – reboot and we should be ready, right?

“Internet Information Service not installed”

After the patching you have to start the Config Wizard. I was a little surprised as it responds with a nice error –  I even tried the PowerShell command in case there is a difference, but no:

Terminals 3.4.0 (Files store)_2014-02-21_15-12-49

What? IIS not installed anymore? Something must be broken with the Patch – let’s blame Todd for it:

But then I tried to reproduce my steps – of course it must be an user error. After reading the patch script (reading things sometimes helps), I noticed that the script disables the IIS Admin service…

Terminals 3.4.0 (Files store)_2014-02-21_15-31-32

SharePoint does not like that – set it back to Automatic start and start the service.

Starting the site is a good idea, too:

_2014-02-21_16-11-08

And then start the config wizard again:

_2014-02-21_16-11-45

And wait until every database is updated:

Terminals 3.4.0 (Files store)_2014-02-21_16-15-49

Search “Paused for:External request”

Then I tried do do a Search – without a success. I went to the Search Service Application page and saw the status: “Paused for:External request” – that means something paused the Service Application (maybe, just maybe someone tried to patch):

Terminals 3.4.0 (Files store)_2014-02-21_16-28-37

and we should resume it – 3 lines of PowerShell:

Lessons learned

Patching can be tough – but when you protocol what you do or can at least reproduce what you have done its pretty much straight forward. I do not blame the patch script here, I obviously did something wrong – but the error message is really misleading isn’t it?

FAST for SharePoint 2010 – Cumulative Update August 2012

05 Apr 2013
April 5, 2013

The Cumulative Update August 2012 for FAST Search Server for SharePoint 2010 is out for a while now – seems like nobody has tried this one yet. Or quality control has happened…

Updating FAST Search

When you install a service pack or a cumulative update for FAST you have to run the setup and then you have to start a FAST powershell and start “psconfig –action p” – otherwise your search won’t work because SAM Worker process is dead.

Cumulative Update August 2012

So what happens when you install the update? The installation went fine – I rebooted my server and then, as usually, I started the powershell to start the patch command! BAM!

fast_cu2012_aug_patchfail

Epic quality check fail!

Wonderful!

Solution

At least the fix for this problem is quite simple – and the powershell error is really helpful this time.

Open the file “<FASTInstall>\installer\scripts\include\commontasks.ps1” and go to line 169. Replace $script:$HOST_CONFIG_HOST_NAME with $script:HOST_CONFIG_HOST_NAME. Save the file and then start the patch again with “psconfig –action p” in the installer\scripts folder. After patching check with nctrl status if the SAM Worker is alive again.

fast_cu2012_aug_patchfix

Easy fix – just remove the $

Still, unbelievable.

SharePoint Toolbox #012: AutoSPSourceBuilder

11 Mar 2013
March 11, 2013

Today a new webcast on the SharePoint Toolbox was released. It’s about the very cool AutoSPSourcebuilder powershell script.

Summary

The webcast shows you how to create SharePoint 2013 installer package with bundled Prerequisites (so you can install SharePoint without Internet-Connection) and includes the SharePoint 2013 Cumulative Update December 2012. Language packs or even Service packs could be added, too.

Its available in English and German.

Feedback, questions or tool suggestions much appreciated.